首页   注册   登录

crayygy

好好学习
V2EX 第 121849 号会员,加入于 2015-06-11 21:14:25 +08:00
今日活跃度排名 71
我就不说话,默默学习
crayygy 最近回复了
感谢,已收藏
我以前是不用第三方输入法的,觉得自带的也挺好用。
自从用了 Google App 里面带的那个 Gboard, 原生输入法再也用不下去了,联想功能很弱,也不支持模糊识别,也没有滑动输入。
3 天前
回复了 0526 创建的主题 Apple airpods 还有必要在入手吗?
我半年前买的 999 …
3 天前
回复了 oncewosiwo 创建的主题 职场话题 面试碰到求斐波那契数列第 n 项
7 天前
回复了 aijam 创建的主题 分享创造 总结了一些减少 bug 的方法
less codes, less bugs🌚
8 天前
回复了 alex1504 创建的主题 分享创造 程序员与 Kindle 会碰撞出怎样的火花?
最后发现,iPad Pro 才是最好的阅读器,支持 epub,支持 PDF(PDF Expert 很好用啊),支持 Kindle 上的所有(Kindle 官方),支持微信读书(现在资源挺多的)
9 天前
回复了 xmi 创建的主题 宽带症候群 我的 4G 网速在本站处于什么水平?
已经用了 20GB,那得看看联通有没有哪个页面底下的小字写着超过多少限速了。我自己体验下来的情况,这种网速还只有移动会这样
1L 说的很清楚了,我再补充一点额外的好了。

所谓的 Android 6.0 加入了动态权限申请机制,需要达成两个条件。
1. 机器的 Android OS version >= 6.0
2. Application 的 targetSdk >= 23 (也就是 Android 6.0 的 SDK version)

在 Android 6.0 发布的时候,为了避免出现应用不能向上兼容的情况,所有 targetSdk < 23 的应用还可以继续下载安装,但是在 Google Play 上,下载之前会有一个 popup 告诉你,这个应用都申请了哪些权限。 你可以在系统设置里面关掉这个 App 对应的权限,但是不保证能够正常工作(因为 App 可能没有 check 没有权限的情况)。

而当应用 targetSdk >= 23 以后,在编写代码的时候必须实现动态权限申请,否则根本没办法使用权限。而很多应用为了逃开这个限制,选择了继续 targetSdk 到 22。但是编译的 SDK version 提升。比如我曾经见过的 网易云音乐,targetSdk 22,但是却使用了 Android 7.0 的新功能。

为了解决这个问题,Google 从去年开始实施一个规定(针对 Google Play ),到 2018 年 11 月以后,所有的应用要上架、更新,必须 targetSdk 到 Oreo 以上,而从 2019 年开始,上架、更新应用的 targetSdk 版本必须是一年以内发布的版本(这条规则比较绕,我们也看了好几遍)。

详细的信息可以参考这篇官方文章 https://android-developers.googleblog.com/2017/12/improving-app-security-and-performance.html
1password 有 note 功能的,都不用配置的,还可以检索,建议打开 1p 仔细看看,万一好用呢是吧
13 天前
回复了 clockOS 创建的主题 Apple 微软的市值超过苹果了。
大家都在跌,跌多跌少而已...
关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1958 人在线   最高记录 4019   ·  
创意工作者们的社区
World is powered by solitude
VERSION: 3.9.8.1 · 7ms · UTC 03:05 · PVG 11:05 · LAX 19:05 · JFK 22:05
♥ Do have faith in what you're doing.
沪ICP备16043287号-1