首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  Ruby on Rails

gem安装发生的依赖包问题

  •  
  •   reducm · 2011-12-11 23:00:07 +08:00 · 3708 次点击
    这是一个创建于 2745 天前的主题,其中的信息可能已经有所发展或是发生改变。
    这个问题很怪异,时有时无.
    有时在某些机子上例如用gem install rails,会提示requires xxxx然后要一个个依赖包手动安装下去,依赖又有依赖...按道理gem 是会自动安装依赖包,但是这个功能有时会失效
    想到的解决方法是自己写个递归脚本让他自动装,但这样每递归一次都要更新一次atest文件,速度很慢

    一直都找不到这个是什么原因引起,google 和stackoverflow都找过,有些说是某些gem包用C了会和gcc版本有关系,但各种东西升级到最新还是有这个依赖问题,很奇怪
    1 回复  |  直到 1970-01-01 08:00:00 +08:00
        1
    reducm   2011-12-11 23:16:06 +08:00
    v2ex的seo太强大了!发了10多分钟,搜 'gem 依赖问题'就排google第一了!
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4069 人在线   最高记录 5043   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 18ms · UTC 02:37 · PVG 10:37 · LAX 19:37 · JFK 22:37
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1