首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  Raspberry Pi

树莓派无法使用 putty xshell 登陆 ssh

  •  1
     
  •   qiandongdong · 2017-06-30 18:25:34 +08:00 · 2813 次点击
    这是一个创建于 600 天前的主题,其中的信息可能已经有所发展或是发生改变。
    近期入手了一个树莓派,但是一开始使用的时候就出现问题了,就是刷好系统后,无法登陆 ssh.网上教程我都一一排除了,还是无法解决。

    1.首先,树莓派 IP 在路由器表中是可以找到的,也使用了 IP 工具进行了扫描,确定树莓派的 IP。
    2.用电脑 ping 树莓派的 IP 是可以连通的。
    3.不行系统的问题,我试了刷好几个版本。。
    4.网上教程说的要新建一个无后缀的 ssh 文件,也新建在卡里面了,也是不行。

    ps:putty 登陆错误提示是 Network error:Connection refused
    22 回复  |  直到 2017-07-22 11:13:46 +08:00
        1
    hadoop   2017-06-30 18:28:02 +08:00
    ssh 服务开了吗
        2
    trepwq   2017-06-30 18:29:45 +08:00 via iPhone
    树莓派默认不开 ssh 服务
        3
    7654   2017-06-30 18:31:22 +08:00
    系统是不是 Raspbian ?
    需要运行 sudo raspi-config 或图形界面设置 SSH 开启
    VNC 同样
        4
    qiandongdong   2017-06-30 18:35:32 +08:00
    1.我现在的问题是使用 putty 连接树莓派的 IP 连接不上去 提示:Network error:Connection refused
    2.树莓派默认不开 ssh 服务,我已经新建了 ssh 无后缀文件,这个是网上开启的方法
    3.系统是官方的 Raspbian 我现在是无法连接上树莓派,别说执行其他命令了.
        5
    AsisA   2017-06-30 18:45:04 +08:00 via Android
    @qiandongdong 新建好 ssh 文件后网线直连电脑试试,我是这样连上的,插路由器上一直连不上
        6
    AsisA   2017-06-30 18:47:48 +08:00 via Android
    @qiandongdong 或者换一根网线,也可能是网线的问题
        7
    dane   2017-06-30 18:48:42 +08:00
    https://www.raspberrypi.org/documentation/remote-access/ssh/README.md
    > 3. ENABLE SSH ON A HEADLESS RASPBERRY PI

    For headless setup, SSH can be enabled by placing a file named ssh, without any extension, onto the boot partition of the SD card. When the Pi boots, it looks for the ssh file. If it is found, SSH is enabled, and the file is deleted. The content of the file does not matter: it could contain text, or nothing at all.
        8
    qiandongdong   2017-06-30 19:02:59 +08:00
    @AsisA 我刚刚试了,网线直接连接电脑也是连接不上去,网线是好的,刚刚才买的,新建 ssh 文件也早就新建过了
        9
    qiandongdong   2017-06-30 19:04:26 +08:00
    @dane 都说了,树莓派无法登陆到 ssh,其他命令根本就是无法输入
        10
    misaka19000   2017-06-30 19:16:07 +08:00 via Android
    应该是树莓派 ssh 服务没开启,开启就行了
        11
    xratzh   2017-06-30 19:30:30 +08:00 via iPhone
    刚烧完一个系统:如果是新烧录的 raspbian,新的版本系统是不会默认开启 ssh,需要在 tf 卡两个目录下,有一个目录新建一个 ssh 文件即可。简单地 touch ssh(⁎⁍̴̛ᴗ⁍̴̛⁎)

    当然我还遇到一个情况就是我的 lan 是 192.168.5.1,wifi 设置为 192.168.6.1。系统 tomato,这样也是无法通过 Wi-Fi 设备 ssh 到树莓派的。需要将 ip 换为一个段。其余问题未知
        12
    mengyaoss77   2017-06-30 19:37:28 +08:00
    在 boot 分区下, 新建一个空白 ssh 文件 应该是没问题的。 我前几天刚烧录了一个系统 最新的 raspbian。
    touch ssh 就行了
        13
    qiandongdong   2017-06-30 19:39:36 +08:00
    各位大哥,我都说过了,我已经新建过 ssh 空文件了,还是无法登陆。
        14
    Osk   2017-06-30 19:44:04 +08:00
    所以,建议玩树莓派要么准备显示器,要么准备一个 usb-to-serial 线,淘宝 ft232 才 2、30 元左右,今天是 ssh 登不起,万一某天启动不了了才是真心哭瞎。有 usb 串口对于 headless Linux 来说很重要,相当于一个文本模式的终端了
        15
    mengyaoss77   2017-06-30 21:29:00 +08:00 via Android
    是最新版本的 raspberry 么
        16
    qiandongdong   2017-06-30 21:31:44 +08:00
    @mengyaoss77 2017-06-21 最新镜像
        17
    yushiro   2017-06-30 21:39:46 +08:00 via iPhone
    找个 hdmi 线接下显示器,键盘,不就搞定了嘛!
        18
    wenzhoou   2017-06-30 22:04:39 +08:00 via Android
    不用说。铁定是 ssh 文件的事儿。等你搞好了再回过头来看这个帖子。你就明白了。
        19
    vcfghtyjc   2017-06-30 22:26:59 +08:00
    openssh 安装了吗?用的是 raspbian 吗?
        20
    fisher335   2017-07-01 06:52:33 +08:00 via iPhone
    好像是 raspcinfig 吧!先登图形界面进去开下 ssh,还不行就重刷,我也遇到过怎么都开不了的情况,重刷一下就好了
        21
    qiandongdong   2017-07-03 19:42:35 +08:00
    弄好了,不是没有开 ssh 的问题,我用的是 128G 的 TF 卡,可能是太大了系统不支持,换了 16G 的 TF 卡可以了。
        22
    fox0001   2017-07-22 11:13:46 +08:00 via Android
    同情楼主,决定热心帮助帮助楼主处理掉那可恶的 128g TF 卡!
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3857 人在线   最高记录 4385   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 18ms · UTC 05:46 · PVG 13:46 · LAX 21:46 · JFK 00:46
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1